Jump to content
Sign in to follow this  
STV2.5

1996 2.5 merc mod PROBLEMS!

Recommended Posts

50% of the time motor runs great 50%lugs and won't go over 3000 rpm but in neutral sounds good we pull the plugs and there is oil on them we clean the plugs and most of the time it runs good any ideas

Share this post


Link to post
Share on other sites
50% of the time motor runs great 50%lugs and won't go over 3000 rpm but in neutral sounds good we pull the plugs and there is oil on them we clean the plugs and most of the time it runs good any ideas

The first thing I would do is get brand new spark plugs. Plugs that fouled should be replaced. That would be the cheapest and quickest test to see if the plugs are the problem. If the new plugs dont help. Youve ruled one thing out.

Share this post


Link to post
Share on other sites

Getting back to basics. How's fuel pressure and volume? How's the fuel filter?

Share this post


Link to post
Share on other sites
Getting back to basics. How's fuel pressure and volume? How's the fuel filter?

Not sure about the fuel pressure and volume.....but the fuel filter is brand new.

Any idea why the plugs would be wet?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×