Jump to content
specialkb82

rapair ecu

Recommended Posts

I have recently purchased a STV euroski and have had a few bugs. I had to have the trigger and mercury harness replaced , and the computer was replaced also. The last and i hope final bug is i starts great , runs great , but if i kill it once it is hot and wish to start it back up it floods it and i have to wait to cool down? Well that is what it seems like. The motor is a 300 drag fuel injected horn motor. I am new to this and dont know much , so any comments to help me start in the right direction?

Share this post


Link to post
Share on other sites

Well the guy who worked on it took the yellow with red wire out of the harness ( the starter out of the key ) put it on the coil. Then the yellow with the red wire out of the ECU ( the choke ) and put it on the coil. Then he took the yellow with the black stripe ( the choke out of the key ) and just put it out of the way. So i hooked the Y/R out of key to coil , and then hooked the Y/B out of key to the Y/R out of ECU and it is fine. Like i said i am new to all of this but i will learn lol .

Share this post


Link to post
Share on other sites

So I guess this prevents the engine from flooding...I ask becasue I have a similar conditions after a long run when the engine like you say is Hot and then hard to restart? Yes it has to sit and cool down ...then it is fine?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×